Welcome all 928 forum refugees!
  • User avatar
  • User avatar
User avatar
By hlee96
#83687
Searched through 20 years of Rennlist topics on CIS and wondering if I am on the right track and any recommendations to further improve or send the WUR in to SpecialTauto for rebuild.

History: 1978 #414 sat while I was gathering parts and doing water pump/belt change, along with dragging my @ss. It failed to start before my water pump/belt work when I added gas into the tank while it was idling and likely disturbed the sediments and clogged the fuel pump/filter.

Finally did the right thing and got Stan (MrMerlin) to help.
In summary:
1. New duel fuel pumps (below the tank and inside the rear fender)
2. New Greg Brown fuel lines (both inside the engine bay)
3. New injectors (all 8)
4. Took a few tries to start and finally did and, although a little rough at first, it settled to a nice idle after a few rough runs. However, it would stall when gas is pressed.
5. Ran Techron/Chemotool in the tank and jumpered the system to help to clean the varnish a bit.
a. The car would not start after this.
6. Check pressures: reviewed the CIS gauge to ensure proper connections (it was)
a. System pressure 80-82 PSI (little high but liveable?)
b. Cold control pressure: 80 PSI!
7. Removed and clean every part of the WUR top chamber and inlet screen (plenty of junk and finally cleaned)
a. Easily injected brake cleaner through both the inlet/outlet both sides and liquid easily comes out the other side.
b. Followed by compressed air and cleaned
c. Verified the placements of the diaphragms (one without the off-center hole against the inlet/outlet holes-WUR, followed by the diaphragm with a small off-center hole, followed by the machined plate with a tiny cup in the center for the pin)
8. Rechecked Pressures:
a. System pressure: 80 PSI
b. Cold control pressure: 42 PSI (improved but still ~15-18 PSI too high)
9. Followed Rennlist suggestions/Watson suggestions on quick check on CIS blockage with fuel pump running:
a. Cracked open the inlet to WUR --> Cold control pressure decreased from 42 PSI to ~20 PSI with brisk fuel
b. Cracked open the outlet of the WUR --> Cold control pressure did not decrease with slower fuel leak

So, accordingly, the blockage is still with the WUR between the inlet/outlet of the fuel lines on the WUR. Where do I go? Should I start pressing on the adjusting pin? It is ~2 mm below the WUR surface. Maybe I can tap it and see if it can lower 10-15 PSI? Metal diaphragms looked good. Would the bottom half with the rubber diaphragm of the WUR affect the cold control pressure? It shouldn't according to the concept.

Before going any further, I am thinking about running some BG44K through the system and check again.

Maybe I need to rebuild the WUR with o-rings and all, but I am trying to avoid going into the bottom half.

Thank you for all and any advice/recommendations!
Hoi
User avatar
By Mrmerlin
#86459
Hi Hoi I just saw this and thought i would add a suggestion I had a similar problem with my early cis machine and it needed to have the mixture screw turned CW a bit, you need a longer 3 mm allen wrench to get to the screw.
Mark the position so you can return, let me know what you find

And another short clip https://www.youtube.com/wa[…]

Great thread :rockon: I thought it was a gre[…]

I'll be there, hope that doesn't deter anyone else[…]

Panorama September 2021

great representation ~!