8 cylinder front engine iconic vehicle
  • User avatar
  • User avatar
  • User avatar
User avatar
By fred111
#111096
When I got my 86.5 none of the interior lights worked. I replaced the hatch and overhead fixtures with VW lights and put LED bulbs in those as well as the doors. Now all will work. I had to replace the pin switch under the hatch release as it was broken. Now all of my lights come on together when the hatch is opened. No lights come on with opening doors. Both door pin switches seem ok. I sanded the contacts just in case. My hatch release motor only runs with the hatch open. Can anyone point me to anything to check?
Thanks
User avatar
By fred111
#111122
It was attached when I pulled them out to brush them off. Would they always be on if they weren't making contact? I also haven't gotten the red lights in the door working yet in case that affects the others coming on.
User avatar
By Geza-aka-Zombo
#111135
I had a similar problem that I recently fixed. What I found is the hatch opener will not work unless the door lights are on - safety feature so that hatch can't be opened while driving. This is why it is only working for you when the hatch is open (door lights are on).

Check your interior light relay. Jiggle it around in the fuse panel and see if the door lights flicker. Perhaps you have the same issue I had.

See thread: Intermittent interior lights, which relates to hatch release
User avatar
By fred111
#111251
Geza-aka-Zombo wrote: Thu Oct 21, 2021 10:30 am I had a similar problem that I recently fixed. What I found is the hatch opener will not work unless the door lights are on - safety feature so that hatch can't be opened while driving. This is why it is only working for you when the hatch is open (door lights are on).

Check your interior light relay. Jiggle it around in the fuse panel and see if the door lights flicker. Perhaps you have the same issue I had.

See thread: Intermittent interior lights, which relates to hatch release
That may be a problem. No relay XXI. I guess the PO took it out diagnosing maybe?
User avatar
By fred111
#113304
I got a relay and my lights all came on with the driver door open. Unfortunately they stay on all of the time. The two door lights are stock. The other three are VW. The VW lights all operate correctly going by the symbols on the light. Does that mean I have them wired correctly or could they still be wrong? The hatch release now operates right when I have the relay installed.
User avatar
By Geza-aka-Zombo
#113451
Just a quick thought - the lights are now on a timer, so it takes 20 seconds or so to turn off once you close the door. Did you wait long enough to see if they go out?
User avatar
By Geza-aka-Zombo
#113500
Try disconnecting the small connector on the right side (when looking into the hatch) near the hatch latch strut behind the tool kit. Small brown 2 pin connector, as I recall.
User avatar
By fred111
#113618
Disconnecting the hatch pin switch has no effect. They all stay on. The hatch switch was the first thing I replaced when I started working on the lights and hatch opener. I can still take out the relay and lights work correctly when opening the hatch only. I found out that the hatch switch doesn’t involve the relay.
User avatar
By Geza-aka-Zombo
#113653
I think the next thing I would try is pull both door pin switches so they no longer can make a ground connections, put the relay in and see what happens. Lights should not turn on unless there is a short to ground somewhere. Assuming they don't turn on, ground each pin switch separately with the pin in and out and see what happens.
User avatar
By fred111
#113855
Success! I took the door switches out. Apparently the wires on both came loose the last time I put them in while checking. I fished them out and reconnected and everything works as it should! I guess the missing relay and hatch pin switch I replaced were all that was wrong. I appreciate the help with this! :rockon:
SeanR, Bertrand Daoust, 7-51 liked this

:eek:

Good to know on the Sharktuner (I have never owned[…]

Where's GB?

he posted yesterday. he has seemed to dial back t[…]

If you decide to make a sub-loom for COP, I have[…]